wordpressでslickを実装したらコンソールエラーがハンパなかった件

wordpressでslickを実装したらコンソールエラーがハンパなかった件

jQueryのバージョンと重複にご用心

word pressにてslickを実装したのですが、そのページだけ「トップへもどる」のボタンが反応しなくなりました。
またまたjsの噛み噛みでぶつかったかなと思い、
コンソールを見てみると、

というエラーが無限に増殖している状態でした。
この時点でヒーーーーとなるわけですが、
色々試したところ、

どうもカプセル化云々のことではではないらしい

という感じでした。
そこで発見した記事がこちら↓

WordPressでjQueryを使うときに、問題なく動作させる為の基礎知識やTipsと、動かない場合の対処例

どうやらwpがデフォで読み込んでいるjQueryと
slickで読ませたいjQueryがケンカをしている模様でした。
で、こちらの記事の「WordPress × jQueryのベストプラクティス」という項目にあった、

WordPress本体のjQueryを使用しないようにする

を実行です!
header.phpのwp_head()よりも上に以下を書くそうです!

私の場合はjquery-1.11.0.min.jsを読み込みたかったので、以上の記述になりました。
実装したところ、無事無限エラーはなくなり、トップへボタンも動きました!ヤッホーイ!ハラショーー!

基本的にjQueryは重複して読み込むものではないので
今後は充分注意していきたいです。
表示スピードに関わってきますしね。。
単純な様でダメージは大きいです。

解決してよかった!
安心安心。

Back to Top